Degraded performance logging into Expander
Incident Report for Expanse
Resolved
We have implemented a fix to resolve the issue. Service has been restored to all customers.
Posted May 13, 2022 - 01:56 UTC
Investigating
Our systems have detected an internal issue that causes delay on logging into Expander. Our engineering team is aware of this issue and is actively working on a fix.
Posted May 13, 2022 - 01:31 UTC
This incident affected: Expander USA - A.